更新Android模拟器在Android Studio中3.3失败

问题描述 投票:1回答:3

我的Android工作室升级到3.3。模拟器版本是28.0.22。

现在,新版本28.0.23版本库中:

enter image description here

当我想更新到新版本我得到了错误:

2019-02-03 16:43:06,975 [hread 1030]   INFO - ectedPackagesStep$CustomLogger - Packages to install:  
2019-02-03 16:43:06,975 [hread 1030]   INFO - ectedPackagesStep$CustomLogger - - Android Emulator (emulator) 
2019-02-03 16:43:06,975 [hread 1030]   INFO - ectedPackagesStep$CustomLogger - 

2019-02-03 16:43:06,977 [hread 1030]   INFO - ectedPackagesStep$CustomLogger - Preparing "Install Android Emulator (revision: 28.0.23)". 
2019-02-03 16:43:06,980 [hread 1030]   WARN - ectedPackagesStep$CustomLogger - Failed to read or create install properties file. 
2019-02-03 16:43:06,980 [hread 1030]   WARN - ess.util.ProgressIndicatorBase - This progress indicator is indeterminate, this may lead to visual inconsistency. Please call setIndeterminate(false) before you start progress. 
2019-02-03 16:43:06,980 [hread 1030]   INFO - ectedPackagesStep$CustomLogger - Preparing "Install Android Emulator (revision: 28.0.23)". 
2019-02-03 16:43:06,984 [hread 1030]   WARN - ectedPackagesStep$CustomLogger - Failed to read or create install properties file. 
2019-02-03 16:43:06,984 [hread 1030]   INFO - ectedPackagesStep$CustomLogger - Failed packages: 
2019-02-03 16:43:06,985 [hread 1030]   INFO - ectedPackagesStep$CustomLogger - - Android Emulator (emulator) 

这是怎么回事?

android android-studio
3个回答
1
投票

同样的事情发生在我身上。我不得不这样做完全安装的新的仿真程序版本,而不是更新它。

我不知道失败的原因,虽然


0
投票

我终于安装模拟器新version.I觉得它是如此安装的命令行机器人工作室GUI错误:

sdkmanager "emulator" --proxy=http --proxy_host=127.0.0.1 --proxy_port=8118

现在每想到是确定的。我希望这一点,帮助别人卡住在这种情况下


0
投票

当我弹出窗口,“Android模拟器 - 可用的更新”,我刚才点击和更新。

尝试运行Android的工作室担任管理员,可能它会奏效。

enter image description here

希望它会为你工作也。

热门问题
推荐问题
最新问题