这个RMagick的安装配置了ImageMagick 6.6.9,但ImageMagick 6.7.7-10正在使用中

问题描述 投票:14回答:3

在rails应用程序中,我有以下错误消息:

This installation of RMagick was configured with ImageMagick 6.6.9 but ImageMagick 6.7.7-10 is in use.

我尝试按照这篇文章中的建议卸载并安装RMagickRMagick complains it was configured with a different version of ImageMagick,但它不起作用。

我也尝试下载最新版本并从源代码编译,但它不起作用。

我不知道如何安装ImageMagick 6.7.7-10。它似乎无法在官方网站上找到。

我正在使用rmagick (2.13.2)和Ubuntu 14.04。

有解决方案吗?

ruby-on-rails ruby imagemagick rmagick
3个回答
18
投票

我终于找到了解决方案。而不是做gem uninstall rmagick尝试使用bundle exec gem uninstall rmagick

我希望它会帮助别人!


4
投票

对我来说,我做了以下工作:

 gem uninstall rmagick
 bundle

0
投票

捆绑exec卸载rmagick,卸载RMagick。


推荐问答