composer提供linux上的openssl错误消息php7

问题描述 投票:0回答:1

我在arch上安装了PHP 7,它直接随PHP核心一起提供了openssl。作曲家似乎无法识别它,并给了我这个错误:

[Composer \ Exception \ NoSslException]openssl扩展是SSL / TLS保护所必需的,但不是必需的可用。如果您无法启用openssl扩展名,则可以通过设置“ disable-tls选项设置为true。

我不想禁用TLS。我试图将这个模块包含在php.ini中,并使用各种名称,例如opensslphp_opensslopenssl.sophp_openssl.so,但这些都不起作用。

UPD0:我正在使用Apache2。

UPD1:发行:Arch。

UPD2:我已禁用作曲家TLS保护,但收到另一条错误消息:

[RuntimeException]您必须在php.ini中启用openssl扩展名才能加载来自https://asset-packagist.org的信息>

我在arch上安装了PHP 7,它直接随PHP核心一起提供了openssl。 Composer似乎无法识别它,并给了我这个错误:[Composer \ Exception \ NoSslException] ...

php linux apache openssl
1个回答
0
投票

我刚刚用标志--with-openssl编译了PHP

热门问题
推荐问题
最新问题