Maven无法解决依赖性

问题描述 投票:0回答:3

我在spring-boot项目中遇到问题。

Cannot resolve com.didisoft:pgplib:3.1.2.1

当我尝试导入此依赖项时抛出此错误-

    <dependency>
        <groupId>com.didisoft</groupId>
        <artifactId>pgplib</artifactId>
        <version>3.1.2.1</version>
    </dependency>

我正在检查时

/.m2/repository/com/didisoft/pgplib/3.1.2.1/ 

文件夹,我所拥有的只是这两个文件

pgplib-3.1.2.1.jar.lastUpdated and pgplib-3.1.2.1.pom.lastUpdated

我也尝试过在.m2 / settings.xml中添加didisoft存储库,但仍无法解决问题

java spring-boot maven dependency-management
3个回答
1
投票

您是否曾尝试根据此instructions将您的信用凭证放入settings.xml?


-1
投票

您是否尝试运行mvn clean install -U


-1
投票

如果您确定您的凭据在]中,则>

 Settings.xml 
推荐问答
热门问答
最新问答