无法在Win系统上的Ubuntu虚拟机中安装Scrapy(Shell)

问题描述 投票:0回答:2

我是VM的新手,但正在关注这本书 - DKL的Learning Scrapy。它似乎是通过Vagrant和VirtualBox建立一个虚拟环境。我想我已经完成了所有设置 - 安装了ubuntu 12.04.5 LTS的Vagrant和VirtualBox。

然后我使用Cmder.exe(在我的项目文件夹e:... \ Project中)访问Vagrant

λ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Machine already provisioned. Run `vagrant provision` or use the `--provision`
==> default: flag to force provisioning. Provisioners marked to run always will still run.

λ vagrant ssh
Welcome to Ubuntu 12.04.5 LTS (GNU/Linux 3.2.0-23-generic x86_64)

 * Documentation:  https://help.ubuntu.com/
New release '14.04.5 LTS' available.
Run 'do-release-upgrade' to upgrade to it.

This Ubuntu 12.04 LTS system is past its End of Life, and is no longer
receiving security updates.  To protect the integrity of this system, it’s
critical that you enable Extended Security Maintenance updates:
 * https://www.ubuntu.com/esm

Welcome to your Vagrant-built virtual machine.
Last login: Sat Sep 15 23:40:43 2018 from 10.0.2.2

vagrant@precise64:~$ sudo apt-get install scrapy
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package scrapy
python ubuntu scrapy vagrant scrapy-shell
2个回答
0
投票

你可以试试:

sudo apt-cache search scrapy

找出包名。在新的Ubuntu系统上,包名是python-scrapy,因此:

sudo apt-get install python-scrapy

0
投票

您可以随时使用pip安装Scrapy:

pip install scrapy
热门问题
推荐问题
最新问题