mod_fcgid:在40秒内读取数据超时

问题描述 投票:2回答:2

我们在只有一个网站的大型专用服务器上运行centos / cPanel。我们需要速度和能力来上传'nobody'下的文件。这意味着suPHP和DSO都出局了。所以php处理程序是mod_fcgid。不时apache错误日志会显示mod_fcgid:在40秒内读取数据超时。我们假设这意味着使用easyapache安装时未正确配置mod_fcgid。

在阅读了关于如何解决的问题后,我们发现了两个花絮。一个涉及MPM。令人惊讶的是,另一个显示了如何增加超时响应(通常增加超时响应是坏事,因为服务器内部有更糟糕的事情)。

我们应该使用mod_fcgid使用MPM事件,prefork和/或worker吗?我们目前已配置prefork。

如果我们确实增加了超时,我们应该使用以下设置:

IPCConnectTimeout 20
ProcessLifeTime 120
IdleTimeout 60
IdleScanInterval 30
MaxRequestsPerProcess 499
MaxProcessCount 100

要么

FcgidProcessLifeTime 8200
FcgidIOTimeout 8200
FcgidConnectTimeout 400
FcgidMaxRequestLen 1000000000

如果我们确实使用其中任何一个设置,应该在哪里设置:1)在php.fcgi脚本中,或者2)Apache中的FastCGI配置。

mod-fcgid
2个回答
0
投票

我测试的解决方案,同样的问题

目标配置文件:

/US人/local/Apache/conf/includes/怕热_virtual host_global.conf

目标价值 :

FcgidIOTimeout

应用更改:

/脚本/ rebuildhttpdconf

/etc/init.d/httpd restart

参考:https://wiki.mikejung.biz/Fcgid#FcgidMaxRequestLen


-2
投票

/etc/Apache2/魔导师-enable/防城港ID.conf

* / mods-available / fcgid.conf * / sites-enable / site.com.vhost

<IfModule mod_fcgid.c>
   AddHandler fcgid-script .fcgi
   IdleTimeout 300
   BusyTimeout 300
   ProcessLifeTime 7200
   IPCConnectTimeout 300
   IPCCommTimeout 7200
</IfModule>