Filebeat fields_under_root无效

问题描述 投票:0回答:1

这是我的Apache模块设置

- module: apache2
  access:
    enabled: false
  error:
    enabled: true
    prospector:
       fields:
          beat.name: xxxx
    fields_under_root: true

但是因为我查看了Kibana中的日志

"fields": {
  "beat": {
    "name": "xxxx"
  }
},
"@version": "1",
"host": "something_else",
"beat": {
  "hostname": "something_else",
  "name": "something_else",
  "version": "6.2.4"
},

根据该文件,它说如果我设置fields_under_root: true,它将覆盖现有的根域。但似乎并没有这样做。

  • Filebeat 6.2.4
  • Logstash 6.2.4
elasticsearch logstash filebeat
1个回答
0
投票

正如您所发现的,您可以通过将prospector添加到模块配置来覆盖任何模块的prospector选项。任何探矿者选项必须缩进,以便他们成为prospector的孩子。你的fields_under_root缩进有点错误。

- module: apache2
  access:
    enabled: false
  error:
    enabled: true
    prospector:
      fields:
        vhost: stackoverflow.com
      fields_under_root: true

但是你不能通过使用beat.name覆盖fields。设置此值的唯一方法是将name: xxxx添加到filebeat.yml。

参考文献:

热门问题
推荐问题
最新问题