升级到图形api> v2.8必须吗?

问题描述 投票:2回答:1

我收到了facebook开发者的电子邮件:

v2.8升级提醒您的应用程序APPNAME目前正在访问Graph API v2.8,它将在2019年4月18日的2年生命周期结束时使用。我们估计APPNAME调用的1个端点将受此更改影响,并且可能自动升级推送后停止工作。为确保顺利过渡,请将所有调用迁移到Graph API v2.9或更高版本。使用API​​升级工具可以准确了解此更改将如何影响您的应用。

我的应用程序使用以下方式执

FBSDKAppEvents logEvent

我目前没有使用日志,我不想将新版本发布到应用程序商店,只是为了这个。那么,我可以保留2.8版本吗?

我的应用程序会因使用已弃用的版本而崩溃吗?

提前致谢!

ios facebook facebook-graph-api
1个回答
1
投票

您可以首先升级到测试人员或开发人员facebook帐户的最新版本进行测试(升级调用app角色选项 - 在右侧)

使用测试人员或开发人员fb帐户运行应用程序,如果一切正常,请升级所有用户(升级所有呼叫 - 在左侧)

检查“角色”部分中的帐户角色(高级下方)

这里描述https://developers.facebook.com/docs/apps/upgrading/

这些是后端的东西,似乎通常不需要客户端更新。

enter image description here


推荐问答