pip 相关问题

用于有关Python包安装程序的问题

python 脚本文件夹为空

安装时选择了pip,但是当我检查脚本文件夹时,该文件夹是空的 由于缺少脚本,我无法在终端上使用 pip cammand,编程新手请帮助我! 我试过了

回答 6 投票 0

如何让pip安装我当前源码包的依赖项而不实际安装该包?

根据许多建议,我们正在弃用requirements.txt,因此现在开发人员纯粹基于setup.py和pyproject.toml中描述的依赖项(如果想构建它)。 上一页...

回答 1 投票 0

python安装wheel导致导入错误

我想制作一个wheel二进制发行版,安装它,然后将其导入到python中。我的步骤是 我首先创建轮子: python ./my_package/setup.py bdist_wheel 我安装轮子:pip ins...

回答 5 投票 0

无法在 mac 上 pip 安装 jupyter

我正在尝试在Mac上安装jupyter, 据我所知,mac 自带安装了 python 版本 但我还安装了brew,并通过brew安装了python。 当我检查 python 位置时,我得到:...

回答 2 投票 0

Brew install python 不再指向 python

我正在尝试在Mac上安装jupyter, 据我所知,mac 自带安装了 python 版本 但我还安装了brew,并通过brew安装了python。 当我检查 python 位置时我...

回答 1 投票 0

在 Python 中安装 pyAudioAnalysis

我是 Python 新手,我需要安装“pyAudioAnalysis”才能比较 ML 类的文件。 我目前在 windows>anaconda>python 下工作 当我写下

回答 1 投票 0

无法在 Ubuntu 中安装“pip3”

$ sudo apt install python3-pip 正在阅读包裹清单...完成 构建依赖树 读取状态信息...完成 软件包 python3-pip 不可用,但被另一个软件包引用。 ...

回答 1 投票 0

Mysqlclient 无法通过 pip 安装,在 Ubuntu 中找不到 pkg-config 名称

我对 Linux 和 VM 总体来说是新手。我目前正在尝试在干净的 Ubuntu Jammy 64 (22.4) vbox 实例上安装 mysqlclient。预先运行以下命令: sudo add-apt-reposit...

回答 5 投票 0

Windows 10 上 venv 中的 pip:“启动器中出现致命错误:无法使用 '"c:\users\..." 创建进程' 在 Flask 教程中遇到

我正在学习 Flask 教程,遇到一个问题,无法在 Powershell 中使用 pip(以及其他任何东西)a venv。相同的 Flask 应用程序可以在 Ubuntu 终端中正确运行...

回答 0 投票 0

linux 上 chromebook 上的 Visual Studio 代码,由 crouton 编写(终端中的 xenial)

按照标题..我有戴尔 chromebook,但它没有证书(也有 LINUX Beta) ,所以我在 chromebook 上安装了 linux by crouton。之后,我安装了 Visual Studio Code 和 Python ...

回答 1 投票 0

如何在 Jupyter 单元上运行 PIP 安装命令

我认为我们可以通过在 Jupyter 单元上运行类似的操作来运行 PIP 安装或 PIP 卸载。 %pip 安装 myPackage 但系统会提示我这样确认: 继续(是/否)? 我该怎么办

回答 6 投票 0

Python MariaDB pip 安装失败,缺少 mariadb_config

我正在使用 Linux Ubuntu 18.04 和 python 3。我正在尝试在 maria-db 和我的 python 脚本之间建立连接。因此我必须安装 mariadb 包。 我已经安装了: 苏...

回答 5 投票 0

使用来自 GitLab 的标志“--index-url”和“--extra-index-url”进行 pip 安装会导致“错误:获取时出现 HTTP 错误 404”

我们使用私有 GitLab Enterprise 安装来存储 Python 模块,如包注册表中的 PyPI 包一文中所述 在容器内使用以下命令来

回答 2 投票 0

如何确定Python中特定包名称可用的Python包的数量?

Python 包在与不同 Python 版本和平台的兼容性方面有所不同。例如,在 PyPI 上“cffi”等于 1.16.0 版本包的情况下,您可以找到

回答 1 投票 0

为什么 Python 在我的包中留下不存在的文件?

无论出于何种原因,当我使用 pip install --break-system-packages --user git+https://github.com/zurgeg/pie.git@ed00801 安装我的软件包 pie 时,它由于一个神秘的原因而失败幻像文件: 回溯 (

回答 1 投票 0

为什么我会得到 /usr/bin/python: No module named pip

当我执行 python -m pip install 'uwsgi==2.0.*' 时 我越来越: /usr/bin/python:没有名为 pip 的模块 哪个点给出: /home/snowcrash/.local/bin/pip 如果我做 pip 我得到: 点 回溯(最近的调用...

回答 2 投票 0

ModuleNotFoundError:即使安装也没有名为“flask_mysqldb”的模块

我正在使用 mysql 和 Flask 来开发一个基本网站,即使我安装了模块,我也会收到 ModuleNotFound 错误。有人能解决这个问题吗? 文件“c:/Users/prshi/Desktop/Py f...

回答 1 投票 0

Autogen 任务在没有 pip 的情况下失败; pip3 可以工作,但 pip 不行

我使用Python 3.11来安装和使用Autogen。运行时,Autogen 无需人工输入即可编写和执行代码,并且(据说)可以调试错误并重写代码以完成您分配的任务...

回答 1 投票 0

Pip 不需要 root 用户安装,但需要 root 用户升级

我对预期的点用法感到困惑。 Pip 随 Python 一起安装,这很棒,但是当新版本发布时我收到以下警告: 警告:您正在使用 pip 版本 21.1.1;怎么样...

回答 3 投票 0

当 Numpy 已安装时,出现“无法为 numpy 构建轮子,这是安装基于 pyproject.toml 的项目所必需的”

我正在尝试安装 opencv-python 来执行一些机器学习/基于图像的项目,但是每次我尝试通过 pip 安装 opencv-python 时,它都会在中途给出以下输出: 呃...

回答 1 投票 0

© www.soinside.com 2019 - 2023. All rights reserved.