xcode6 相关问题

Xcode 6是Apple的集成开发环境(IDE)。此标记仅应用于有关Xcode本身的问题,而不适用于一般的Mac或iOS编程主题。对于Mac编程问题使用[cocoa],对于iOS编程问题使用[cocoa-touch]或[ios]。


“dyld:无法加载插入的库'/usr/lib/libgmalloc.dylib',因为找不到图像”

当我在设备8 Beta 2上运行Xcode IOS 6 beta 2固件中的应用程序时,我收到错误消息:“dyld:无法加载插入的库'/ USR / Library / libgmalloc.dylib”,因为图像是.. 。

投票 19 回答 6

无法添加Alamofire与cocoapods项目

我正在尝试使用Cocoapods将Alamofire添加到我的项目中,在快速启动时做同样的事情,更改pods文件,但仍然无法导入Alamofire。我还有什么必须做的吗?

投票 0 回答 1

什么是Xcode中的嵌入式二进制文件?

我在Swift项目中使用Alamofire,他们手动安装说明的一部分是在我的应用程序目标的常规选项卡中的嵌入式二进制文件下添加Alamofire。什么是嵌入式......

投票 50 回答 3

构建纯Swift可可触摸框架

我正在使用Xcode-6探索Swift,到目前为止一直都很好,尽管我认为新的集合需要一些工作,因为我已经设法打破了编译器几次。问题是我现在卡住了...

投票 35 回答 5

使用CocoaPods post install hook将自定义路径添加到HEADER_SEARCH_PATHS

我正在尝试使用post install hook将$(PLATFORM_DIR)/ Developer / Library / Frameworks路径添加到Specta目标Header搜索路径。这显然不是至关重要的,但真的很烦我添加这个...

投票 7 回答 1

Swift:不能用存储属性覆盖,'required'初始化'init(coder :)'必须由'UIViewController'的子类提供

我有下面的代码:import UIKit class tabBarVC:UIViewController,UITabBarControllerDelegate {var tabBarController:UITabBarController // ERROR1:无法覆盖存储的属性'...

投票 0 回答 2

可以使用iOS 8模拟器测试应用内购买吗?

它似乎有效,直到我收到消息警告:您已购买此应用程序内购买但尚未下载。

投票 1 回答 1

在Xcode中更改快速帮助文档语言

这可能是一个Xcode 6错误,但点击或选项单击时的一些系统方法显示Swift中的快速帮助文档而不是Objective-C,这是我正在使用的开发语言...

投票 1 回答 1

无法上班CocoaPods和Yosemite

我已尝试过以下步骤:打开Xcode 6打开首选项单击“位置”选项卡将“命令行工具”版本更改为Xcode 6.0卸载cocoapods a。 $ sudo gem uninstall cocoapods安装...

投票 7 回答 6

如何拦截在AVPlayerViewController中点击完成按钮?

我在自定义UIViewController的viewDidAppear方法中创建了一个AVPlayerViewController和一个附加的AVPlayer。但是,当我按下“完成”按钮时,我的自定义视图控制器被取消...

投票 17 回答 8