yum 相关问题

yum是一个软件包管理器,用于在基于RPM的系统上安装,更新和删除软件包。


通过“用户数据”(Amazon Linux)通过cloud-init启用EPEL

我正在尝试通过“用户数据”功能(使用cloud-init)在AWS中启动基于Amazon Linux的EC2实例后安装p7zip包:#cloud-config repo_update:true repo_upgrade:all ...

回答 3 投票 0

在.repo文件中给出特定版本时,yum如何知道查看最新版本?

我正在查看有关在EC2实例上安装Mongo的说明。我将以下内容添加到/etc/yum.repos.d/mongodb-org-4.0.repo [mongodb-org-4.0] name = MongoDB Repository baseurl = https:// repo ....

回答 1 投票 0

Jenkins中的Ansible Playbook错误

我写了一个简单的剧本来安装httpd。这是我的剧本:--- - 名称:安装httpd hosts:localhost成为:root vars:inputvariable:“{{lookup('file','/ ...

回答 1 投票 1

RPM中的特定最小OpenJDK版本

我在名为MyPackage的rpm中指定了最小的OpenJDK版本。 #rpm -qR MyPackage rpmlib(VersionedDependencies)<= 3.0.3-1 rpmlib(CompressedFileNames)<= 3.0.4-1 rpmlib(...

回答 1 投票 0

修改已安装rpm包的依赖关系

我已经安装了自己构建的rpm包,这取决于php-common。现在,我需要安装一个新的php-common版本。因为它将删除php-common(当前版本)yum告诉我...

回答 1 投票 0

Ansible从rpm包安装yum repo [关闭]

我正在尝试使用Ansible安装rpm包。但是,我无法弄清楚如何正确地做到这一点。我希望有人可以帮助我。这就是我到目前为止所做的:1。使用......

回答 1 投票 2

Linux CentOS YUM错误包需要 - libcrypto.so.10(OPENSSL_1.0.1_EC)(64位)

当我尝试进行“yum update”时,我发现错误,我不确定如何解决。以下是错误消息: - >完成的依赖项解析错误:包:nginx-1.4.7-1.el6.ngx.x86_64(...

回答 1 投票 2

无法执行“yum list”:Errno 5] OSError:[Errno 2]没有这样的文件或目录

操作系统:Oracle Linux 6 [xxx @ host / etc] $ uname -a Linux slc08yld 2.6.39-400.298.2.el5uek#1 SMP Mon Jan 22 13:08:39 PST 2018 x86_64 x86_64 x86_64 GNU / Linux错误是:[xxxx @ host / etc] $ yum list ...

回答 1 投票 -2

使用非工作yum重新安装rhn-client-tools

对于每个yum命令,它将返回SSL证书错误已加载的插件:fastermirror,rhnplugin,security SSL证书验证失败。我的SSL证书有效。我检查了rhel网站...

回答 1 投票 1

检查包更新后是否更改文件

我正在使用CentOS 7.4。这里我有/ etc / bashrc文件名,它来自setup-2.8.71-7.el7.noarch包:#rpm -qf / etc / bashrc setup-2.8.71-7.el7.noarch我已经改变了它并感兴趣现在,如果档案......

回答 2 投票 0
推荐问题