gradle 相关问题

Gradle是一个使用Groovy DSL的项目构建自动化工具。 Gradle构建脚本支持Maven和Ivy存储库以及用于依赖关系管理的纯文件系统。

运行 ./gradlew clean build 时在集成测试中出现初始化错误

我在我的 java Spring boot 项目中使用 test-Containers 编写了一些集成测试。我能够通过 intelliJ 运行测试用例,并且我能够通过运行我的 gradle 任务来运行它们

回答 1 投票 0

原因:org.gradle.api.InvalidUserCodeException:检测到任务“compileDebugJavaWithJavac”的 JVM 目标兼容性不一致

我遇到了这个错误 引起原因:org.gradle.api.InvalidUserCodeException:检测到任务“compileDebugJavaWithJavac”(1.8) 和“kaptGenerateStubsDebug...”的 JVM 目标兼容性不一致。

回答 1 投票 0

如何替换windows中的chmod命令?

我在React Native中运行了一个项目,并收到错误:“无法安装应用程序。请确保您已设置Android开发环境”。我找到了运行命令“c...

回答 2 投票 0

在 Kotlin 中从另一个运行 gradle 任务

我需要了解如何在任务中正确注册任务并添加依赖项。例如,这就是我的任务: 开放类 CodeGeneratorTask: DefaultTask() { @任务动作 有趣的动作(){ ...

回答 1 投票 0

IntelliJ IDEA 未选择 PATH 并且无法找到 npm

Mac OS 14.4.1 上的 IntelliJ IDEA 2024.1(以前的版本也有同样的问题),build.gradle 的相关部分如下所示: def buildAssets =tasks.register('buildAssets') { ... 做最后{ ...

回答 1 投票 0

材质图标扩展包中缺少图标

我正在尝试在 Compose Multi-Platform 中使用手机材质图标。 我在 root/composeApp/build.gradle.kts 中添加了以下行: 科特林{ 源集{ commonMain.依赖项...

回答 1 投票 0

Android studio iguana(补丁1)错误:gradle项目同步失败。基本功能将无法正常工作

我有一个2个月前写的项目,从8.1.3开始我就没有更新过gradle项目了。 今天我打开的时候,遇到了如下错误: 无法同步 gradle 项目。基本的

回答 1 投票 0

Jetbrains Intellij 可以工作,但 Fleet 不能:“不被识别为内部或外部命令、可操作程序或批处理文件。”

尝试使用 Jetbrains 创建的舰队 IDE 进行工作 按照jetbrains网站上的教程进行操作:https://www.jetbrains.com/help/fleet/getting-started-with-java-in-fleet.html 我是

回答 1 投票 0

Compose 编译器需要具有匹配兼容性的 Kotlin 版本

e:此版本 (1.3.2) 的 Compose 编译器需要 Kotlin 版本 1.7.20,但您似乎使用的是 Kotlin 版本 1.9.23,目前尚不清楚该版本是否兼容。 这个错误很容易解释...

回答 1 投票 0

刀柄用ksp代替kapt

如何使用 ksp 代替 kapt 的 hilt 似乎我不明白 请让我知道我应该添加哪些依赖项以及如何添加它们 我添加的依赖项: //刀柄 val hiltVersio...

回答 1 投票 0

发布 Android 库并使用另一个模块作为依赖项

我的项目结构包含 3 个模块::library、:shared 和:internal。 它们之间的依赖关系如下: :library --depends on--> :内部通过实现 :库--取决于--&g...

回答 1 投票 0

如何在 Gradle 插件中引用 libs.versions.toml 文件中的依赖项

我们有以下 Gradle 版本目录文件 libs.version.toml: [图书馆] androidx-compose-material3 = { module = "libs.androidx.compose.material3", version = "1.2.1" } ...

回答 1 投票 0

Gradle 无法解析 Spring Boot HATEOAS 依赖

我从 http://start.spring.io 创建了我的骨架项目。但是当我构建应用程序时,Gradle 无法解析 HATEOAS 依赖项。这是我得到的错误: 错误:java:非法字符 <...

回答 3 投票 0

build.gradle.kts 中的 resConfigs() 已弃用

我正在为 Compose Multiplatform Project 设置新的语言模式。但 resConfigs("uz", "ru") 函数给了我一个弃用通知,该使用什么? 上次我只用旧的

回答 1 投票 0

为什么firebase配合java使用时总是出现包冲突?

我正在将javafx与firebase一起使用,但问题是在构建项目时总是存在冲突poackage,有100个与此类似的错误:错误:模块javafx.controlsEmpty读取包...

回答 1 投票 0

Android Gradle 托管设备 - 无法检索设备错误

当尝试运行多个 gradle 托管设备时,在一台机器上我们收到错误 “无法检索 2 个设备,只有 1 个可用。继续在 1 个分片上运行测试。” 使用这个运行

回答 2 投票 0

如何在 Gradle 中构建 doxygen 文档?

我在 Android Studio 中使用 Gradle。我想通过 org.ysb33r.gradle.doxygen.Doxygen 通过 Doxygen 制作文档。 此时我在 build.gradle 文件中有这个: 导入 org.ysb33r...

回答 2 投票 0

Android gradle 版本 8.2.2 无法构建,多个构建操作失败

// 项目 Gradle 插件{ id("com.android.application") 版本“8.1.4”适用 false id("com.google.dagger.hilt.android") 版本“2.48”适用 false...

回答 1 投票 0

如何避免Gradle多模块项目中多余的configuration.all属性声明?

我正在开发一个Gradle多模块项目,其中服务A(库模块)依赖于最新版本的Guava(33.1.0-jre)。为了确保 Guava 功能正常,服务 A 的 build.gradle

回答 1 投票 0

Java项目中用gradle打包逻辑

我正在尝试使用现有的库创建一个java项目,但我无法准确理解Composite Gradle Build的想法。我有一个 API 项目和一个 webServer 项目,我想导入 API

回答 1 投票 0

© www.soinside.com 2019 - 2024. All rights reserved.