dependencies 相关问题

如果对一个元素的定义的更改可能导致另一个元素的更改,则两个元素之间存在依赖关系。

在pyproject.toml的Setuptools配置中使用Poetry的[tool.poetry.dependencies]

我使用诗歌来处理项目中的依赖项。 诗歌添加包等 它们都在 pyproject.toml 名为 [tool.poetry.dependency] 的部分中指定。前任: [工具.诗歌.依赖项] p...

回答 1 投票 0

如何在android studio中添加房间依赖?

我正在尝试添加这些依赖项,但使用 libs 对象添加其他依赖项,我观看了多个 YouTube 视频,但没有一个视频使用 libs obj,它们只是添加依赖项而没有问题。 这里是...

回答 1 投票 0

本地运行 Angular 应用程序时出现问题 - ng 服务时出错

我是 Angular 新手,在尝试运行使用 Angular 和 .NET 本地构建的系统时遇到问题。下面是我的 package.json 文件,我还附上了错误的屏幕截图和

回答 1 投票 0

在命令行中运行与另一个.jar文件有依赖关系的.jar文件

我有一个 .jar 文件(insertdata.jar),它与 postgresql-42.2.23.jar 具有依赖关系。我也在清单文件中包含了主类。目前这两个文件都位于 C:\Users...

回答 2 投票 0

kotlin 的问题,过时以及如何在 gradle.build 中修复

我一直在阅读这个问题的其他帐户,我的版本需要如何降级,但所有回复都说转到gradle.build,但我的与所有回复不匹配。 andriod/gradle.build Allpro...

回答 1 投票 0

插件 `flutter_webview_plugin` 使用已弃用的 Android 嵌入版本

我已经将flutter版本升级到最新(2.5.2)。当我升级时,一些依赖项也升级了。但其中一些与 null-safe 不兼容。现在我升级了所有依赖项...

回答 2 投票 0

如何仅启用 Polars 板条箱功能的子集?

我在 Rust 中使用 Polars。我注意到,当使用 Polars-core 板条箱而不是 Polars 板条箱时,编译时间显着下降,并给出更小的二进制文件。但是,不鼓励...

回答 1 投票 0

检查 NPM package.json 和 package-lock.json 是否兼容

有没有办法在不运行 npm install 的情况下检查 package-lock.json 文件是否与 package.json 兼容? 兼容意味着package.json指定的版本可以通过package-lock来实现。

回答 3 投票 0

无论版本如何都找不到 spring-boot-starter-oauth2-client

我正在尝试将 spring-boot-start-oauth2-client 导入到我的 pom.xml 中。我尝试过使用不同的版本,无论我使用哪个版本,都会弹出以下错误: 依赖'org.springframework.

回答 1 投票 0

Laravel:安装购物车失败

//我的composer.json { “名称”:“laravel/laravel”, “版本”:“11”, “类型”:“项目”, “description”:“sk...

回答 1 投票 0

使用诗歌在项目文件夹内激活虚拟环境时出现问题:无法停用当前虚拟环境

我有一个全局虚拟环境(my_env),并一直在其中开发我的所有项目。现在我开发了一个新项目,也在 my_env 中,我想使用诗歌创建一个新的、特定于项目的 e...

回答 1 投票 0

Nuget 依赖项不会复制到目标目录(net472 与 net80)

我有一个可以通过插件扩展的项目。插件通过 MEF 加载,因此 EXE 与插件没有直接依赖关系。 下图显示了项目依赖项。 ...

回答 1 投票 0

在 Xcode 空白模板游乐场中添加 Swift 包依赖项

我使用 Xcode Blank Template Playground 因为它对于测试一些代码来说非常轻量级。然而,我在尝试添加 Swift 包依赖项时遇到了一个问题——按钮是灰色的......

回答 1 投票 0

在pypi中找不到库meta_lib和meta_log

我试图使用高通闪存包中的旧脚本(为 QFIL 打包) 检查脚本我发现它是: Python 2.7.18(我对此几乎没有经验。 它使

回答 1 投票 0

升级到 Spring Boot 3.x 和 Spring 6.x 后,如何修复 Java Spring 中 handlerExceptionResolver 的 BeanCreationException?

我的应用程序同时使用 Spring Boot 和 Spring 依赖项。由于 spring-web 存在安全漏洞,我们必须从 5.3.33 更新到 6.x。目前我们使用的是 Spring Boot 版本 2.7.18,...

回答 1 投票 0

STM32MP157F-DK2。软件包 debconf 未安装

我已经使用bitbake为stm32mp157f-dk2构建了一个图像。当尝试安装 Wazuh 时,我遇到以下消息: root@stm32mp1:~# dpkg -i wazuh-agent_4.8.0-1_armhf.deb 选择

回答 1 投票 0

库目标的 add_dependency 和 target_link_libraries 有什么区别?

在CMake中,有什么区别: 添加依赖项(tgt1 tgt2) 和 target_link_libraries(tgt1 tgt2) 当 tgt2 是库目标时? 注意:我的意思不是实现上的差异,我的意思是

回答 2 投票 0

如何运行pipenv install?

我正在尝试在cmd中运行pipenv install。但我不断收到错误 警告:在您的系统上未找到 Python 3.9... 找不到“pyenv”和“asdf”来安装 Python。 你可以具体...

回答 1 投票 0

heif 转换错误:尚未编译 JPEG 支持

我正在尝试将 HEIC 文件转换为 JPEG。 所以我安装了 libheif 库: 我克隆了 https://github.com/strukturag/libheif 我跑了./autogen.sh 我跑了./configure 我跑了 我运行了 sudo make install...

回答 1 投票 0

具有不同版本 Bouncy Castle 的 Java 库

我正在创建一个依赖于符合 FIPS 的 Bouncy Castle 的 Java 库,但我也希望相同的库与常规 Bouncy Castle 兼容 我知道我最终会得到两包...

回答 2 投票 0

© www.soinside.com 2019 - 2024. All rights reserved.